Options

Environment options

To work with environment options, choose Options | Environment Options... menu.

General

Close dataset after report formatting

When previewing, printing or exporting report, the database connection is required only for formatting stage. So, use this option to release database resources after formatting. But when you are developing report and need to test it very often, it is recommended not to set this option for better performance.

Backup template before saving

Make backup copy of the report template with ~DTT extension before its saving.

Automatically check for new version

Allow the application to automatically check for existing of newer Reportizer version. Internet connection is required.

Online Help

Use the online documentation (recommended) instead of the local documentation file (internet connection is required). Alternatively, you can do the following:

  • download the Reportizer documentation file from Reportizer website and place it into the application folder;
  • install free VLS Doc Reader application from the VLSoftware.net;
  • turn this option off.

Note: When you turn this option off, you will need to update the local file from time to time to keep it up-to-date, for example, when new software version is published.

Maximum repository count

Maximum number of repositories in the list of registered report repositories. When the list of repositories reaches the maximum count of repositories, then each new added repository will replace the oldest repository in the list.

Maximum database count

Maximum number of databases in the list of registered databases. When the list of databases reaches the maximum count of databases, then each new added database will replace the oldest database in the list.

View

Integrated preview

Show report preview inside main window instead of the the separate window. This option is also available under View menu.

Preview integrated in main form

Integrated Report Preview

Preview in the separate window

External Report Preview

Report List

These options affect the view of the report list of the main window. Some of them are also available under View menu.

Show file extensions

Show report files extensions (.dtt or .stt).

Show icons

Show report files icons.

Multi-line descriptions

Show report description with word wrapping if it does not fit the grid cell.

Show full descriptions in grid

Show full report description, if it does not fit the grid cell and if Multi-line descriptions is on. With this option turned off, the description can be shown partially if it is to large.

Row color for dynamic reports

Row color for dynamic reports (.dtt) in the grid.

Row color for static reports

Row color for static reports (.stt) in the grid.

Tables

These options affect the view of the tables in the application.

Column headers font

Font for column headers of the tables.

Tool Buttons

These options affect the view of the buttons on toolbars.

Show hints

Show button description when hovering the mouse over the button.

Flat

Show buttons in so called "flat" look.

Transparent

Show buttons partially transparent.

Reports

Always show warnings

Show warnings before every report preview (if any). Warnings can signal potential issues with reports, so suppressing them are not recommended.

Report creating settings

These options are applied to the report when it is created.

Author

Default author for new reports. You can overwrite it anyway in Report Builder.

Report changing settings

These options are applied to the report when it is changed during the editing.

Changed by

Default modifier of the reports when editing them. You can overwrite it anyway in Report Builder.

Confirmations

Creating schema for text table

Ask to create the schema, when you use a text or CSV table as your report data source, but there is no schema describing the file format and table fields yet. When you confirm, a new dialog appears where you can describe the schema.

Editor Options

These are options for configuring code editors like SQL editors, report text editor, or expressions editor. Access them by choosing Options | Editor Options... menu.

Editor options

Customizing syntax highlighting

On the Font and color pane, choose the color scheme: Auto, Light or Dark.

Then specify the common background color and common font for the chosen scheme.

Below, in the left part of the window, select the code element to customize, for example, comment or number. Then, in the color palette to the right, specify foreground color for the selected item by left mouse click, and background color by right mouse click. FG here stands for foreground, and BG stands for background. If you need more colors, find them in the drop-down lists to the right. Below the color picker, specify font attributes for the selected item.

In the very bottom, see how the code looks with specified attributes.

Code writing

On the Code writing pane, choose needed options for helping in writing code or make it more convenient:

Show line numbers

Turn on/off showing line numbers in code editors.

Highlight active line

Turn on/off highlighting active line code editors. Active line is a line with cursor.

SQL completion

Display drop-down lists of SQL keywords, table and field names.

Table names completion

Display drop-down lists of table names from report database. This option require database connection.

Field names completion

Display drop-down lists pf field names after you type period after typing table or table alias name. This option require database connection.

Convert keyword case

Automatically change SQL keywords to uppercase after finishing typing a word.

Smart highlighting

On the Smart highlighting pane, configure smart highlighting of code elements whose text matches the text of the selected fragment:

Enabled

Turn the whole feature on/off.

Case sensitive

Use case sensitivity when searching for matching elements. In case sensitive search, big and small letters (uppercase and lowercase) are treated as different.

Whole words only

Search for whole words only when matching elements.

Font color

Foreground (font) color for found elements.

Background color

Background color for found elements.

Other

These options are available under Options menu.

Disable Report Editing

Disable editing, creating, renaming and deleting reports. You can set up a password protection to prevent unauthorized access to report editing. This option is useful, when the application is used by several people and only some of them have permissions to create or edit reports.

Printer Setup

Default printer settings for the current session.

Language

Choose the application interface language.